Author Topic: Old program - SE_Engine  (Read 776 times)

0 Members and 1 Guest are viewing this topic.

Offline Zlatko Vid

  • Newbie
  • *
  • Posts: 14
Old program - SE_Engine
« on: April 27, 2017, 06:25:29 PM »
Hi to all!
I found on PowerBasic forum old scripting engine called SE_Engine
then i try to compile this demo program with PBWin10
then compiler exit with two errors.
when i comment those lines with errors then i compile program but it looks that cannot run script.
My question is , Is possible to compile that code properly with PBwin10 ?
thanks !

link to post;
https://forum.powerbasic.com/forum/user-to-user-discussions/source-code/36386-se-script-engine?t=35461

Offline Israel Vega

  • Newbie
  • *
  • Posts: 26
Re: Old program - SE_Engine
« Reply #1 on: April 27, 2017, 07:41:18 PM »
Only add THREAD in file  SE_ENGINE.INC

Code: [Select]
THREAD FUNCTION tokenizer(BYVAL inscript AS STRING PTR) AS DWORD     

and now is working fine in PBWIN10

Offline Zlatko Vid

  • Newbie
  • *
  • Posts: 14
Re: Old program - SE_Engine
« Reply #2 on: April 28, 2017, 02:16:57 PM »
Hi Israel Vega
Ok i will add but i don't know where .
I tried to add this line on few places BUT then i receive strange erorrs
like : Must be outside of Sub/Function/Class
do you can explain to me where to add this line ?

Offline Israel Vega

  • Newbie
  • *
  • Posts: 26
Re: Old program - SE_Engine
« Reply #3 on: April 28, 2017, 06:00:59 PM »
Ok...only replace this file:   SE_ENGINE.INC  with I attach.


Offline Zlatko Vid

  • Newbie
  • *
  • Posts: 14
Re: Old program - SE_Engine
« Reply #4 on: April 28, 2017, 07:40:59 PM »
Hi Vega
Yes now work...
so i will study this more..but some things loks overcomplicated without reason.
anyway...thanks again :)